Nginxをインストール

apt コマンドでインストール。パッケージが何種類かあるけど、以前と同じ nginx-extras にした。

takatoh@wplj $ apt search nginx | grep ^nginx

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

nginx/xenial-updates,xenial-updates,xenial-security,xenial-security 1.10.0-0ubuntu0.16.04.4 all
nginx-common/xenial-updates,xenial-updates,xenial-security,xenial-security 1.10.0-0ubuntu0.16.04.4 all
nginx-core/xenial-updates,xenial-security 1.10.0-0ubuntu0.16.04.4 amd64
nginx-core-dbg/xenial-updates,xenial-security 1.10.0-0ubuntu0.16.04.4 amd64
nginx-doc/xenial-updates,xenial-updates,xenial-security,xenial-security 1.10.0-0ubuntu0.16.04.4 all
nginx-extras/xenial-updates,xenial-security 1.10.0-0ubuntu0.16.04.4 amd64
nginx-extras-dbg/xenial-updates,xenial-security 1.10.0-0ubuntu0.16.04.4 amd64
nginx-full/xenial-updates,xenial-security 1.10.0-0ubuntu0.16.04.4 amd64
nginx-full-dbg/xenial-updates,xenial-security 1.10.0-0ubuntu0.16.04.4 amd64
nginx-light/xenial-updates,xenial-security 1.10.0-0ubuntu0.16.04.4 amd64
nginx-light-dbg/xenial-updates,xenial-security 1.10.0-0ubuntu0.16.04.4 amd64
takatoh@wplj $ sudo apt install nginx-extras
[sudo] takatoh のパスワード: 
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
以下の追加パッケージがインストールされます:
  libluajit-5.1-2 libluajit-5.1-common nginx-common
提案パッケージ:
  fcgiwrap nginx-doc
以下のパッケージが新たにインストールされます:
  libluajit-5.1-2 libluajit-5.1-common nginx-common nginx-extras
アップグレード: 0 個、新規インストール: 4 個、削除: 0 個、保留: 431 個。
897 kB のアーカイブを取得する必要があります。
この操作後に追加で 2,692 kB のディスク容量が消費されます。
続行しますか? [Y/n] y
取得:1 http://jp.archive.ubuntu.com/ubuntu xenial/universe amd64 libluajit-5.1-common all 2.0.4+dfsg-1 [35.3 kB]
取得:2 http://jp.archive.ubuntu.com/ubuntu xenial/universe amd64 libluajit-5.1-2 amd64 2.0.4+dfsg-1 [205 kB]
取得:3 http://jp.archive.ubuntu.com/ubuntu xenial-updates/main amd64 nginx-common all 1.10.0-0ubuntu0.16.04.4 [26.6 kB]
取得:4 http://jp.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 nginx-extras amd64 1.10.0-0ubuntu0.16.04.4 [629 kB]
897 kB を 0秒 で取得しました (5,198 kB/s)
パッケージを事前設定しています ...
以前に未選択のパッケージ libluajit-5.1-common を選択しています。
(データベースを読み込んでいます ... 現在 212452 個のファイルとディレクトリがインストールされています。)
.../libluajit-5.1-common_2.0.4+dfsg-1_all.deb を展開する準備をしています ...
libluajit-5.1-common (2.0.4+dfsg-1) を展開しています...
以前に未選択のパッケージ libluajit-5.1-2:amd64 を選択しています。
.../libluajit-5.1-2_2.0.4+dfsg-1_amd64.deb を展開する準備をしています ...
libluajit-5.1-2:amd64 (2.0.4+dfsg-1) を展開しています...
以前に未選択のパッケージ nginx-common を選択しています。
.../nginx-common_1.10.0-0ubuntu0.16.04.4_all.deb を展開する準備をしています ...
nginx-common (1.10.0-0ubuntu0.16.04.4) を展開しています...
以前に未選択のパッケージ nginx-extras を選択しています。
.../nginx-extras_1.10.0-0ubuntu0.16.04.4_amd64.deb を展開する準備をしています ...
nginx-extras (1.10.0-0ubuntu0.16.04.4) を展開しています...
ufw (0.35-0ubuntu2) のトリガを処理しています ...
プロファイル 'Samba' を規定するルールが更新されました
ファイアウォールを再読込しました
ureadahead (0.100.0-19) のトリガを処理しています ...
systemd (229-4ubuntu4) のトリガを処理しています ...
man-db (2.7.5-1) のトリガを処理しています ...
libluajit-5.1-common (2.0.4+dfsg-1) を設定しています ...
libluajit-5.1-2:amd64 (2.0.4+dfsg-1) を設定しています ...
nginx-common (1.10.0-0ubuntu0.16.04.4) を設定しています ...
nginx-extras (1.10.0-0ubuntu0.16.04.4) を設定しています ...
libc-bin (2.23-0ubuntu3) のトリガを処理しています ...
ureadahead (0.100.0-19) のトリガを処理しています ...
systemd (229-4ubuntu4) のトリガを処理しています ...
ufw (0.35-0ubuntu2) のトリガを処理しています ...
プロファイル 'Samba' を規定するルールが更新されました
ファイアウォールを再読込しました

80番ポートを開ける。

takatoh@wplj $ sudo ufw allow http
ルールを追加しました
ルールを追加しました (v6)
takatoh@wplj $ sudo ufw status
状態: アクティブ

To                         Action      From
--                         ------      ----
Samba                      ALLOW       Anywhere                  
22                         ALLOW       Anywhere                  
80                         ALLOW       Anywhere                  
Samba (v6)                 ALLOW       Anywhere (v6)             
22 (v6)                    ALLOW       Anywhere (v6)             
80 (v6)                    ALLOW       Anywhere (v6)

これでOK。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です